Corisoft Software ProjXpert Introduction

ObjectData is a Corisoft Software product.

ObjectData is an object database. It has been developped specifically for the Nokia 7650 smart phone in order to create easily databases that can be viewed through the device. ObjectData databases are organized over a hierarchical tree.

ObjectData is really easy to use and don't require any sophisticated database management system. The databases are compatible on both PC and nokia 7650.

Keep ObjectData software and all important datas on a single Floppy.

ObjectData recognizes and supports all 32-bit Windows desktop operating systems including Windows 95, Windows 98, Windows ME, Windows NT 4.0, Windows 2000, and Windows XP.

All rights reserved. Software Copyright © 1997-2002 Corisoft Software.
http://corisoft.free.fr


License Agreement

IMPORTANT - READ CAREFULLY:

This End-User License Agreement is a legal agreement between you (either an individual or a single entity) and Corisoft Software for the software product identified above, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation ("SOFTWARE PRODUCT").

By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this LICENSE AGREEMENT. If you do not agree to the terms of this LICENSE AGREEMENT, do not install or use the SOFTWARE PRODUCT. Please do NOT order a registration key, if you do not agree to this license agreement.

License conditions
The SOFTWARE PRODUCT is protected by copyright laws and international copyright agreements, as well as other intellectual property laws and agreements. No part of the software or the manual may be multiplied, disseminated or processed in any way without the written consent of Corisoft Software. Violations of these conditions will be prosecuted in every case.

The use of the software is done at your own risk. The manufacturer and developer accepts no liability for any damages, either as direct or indirect consequence of the use or abuse of this product or software by the end-user. The SOFTWARE PRODUCT is being licensed and not sold.

All rights reserved. Software Copyright © 1997-2002 Corisoft Software.

SOFTWARE PRODUCT LICENSE

GRANT OF LICENSE. This LICENSE AGREEMENT grants you the following simple non-exclusive rights:

Applications Software
You may install and use one copy of the SOFTWARE PRODUCT, or any prior version for the same operating
system, on a single computer. The primary user of the computer on which the SOFTWARE PRODUCT is
installed may make a second copy for his or her exclusive use.

Storage/Network Use
You may also store or install a copy of the SOFTWARE PRODUCT on a storage device, such as a network server, used only to install or run the SOFTWARE PRODUCT on your other computers over an internal network; however, you must acquire and dedicate a license for each separate computer on which the SOFTWARE PRODUCT is installed or run from the
storage device. A license for the SOFTWARE PRODUCT may not be shared or used concurrently on different
computers.

OEM License
If you obtained this license agreement together with a hardware product, you are entitled to use this SOFTWARE PRODUCT as a part of the Hard and Software package according to this license agreement.

DESCRIPTION OF OTHER RIGHTS AND
LIMITATIONS

SOFTWARE PRODUCT as Demo Version Even if the SOFTWARE PRODUCT is a demonstration version, it is protected by copyright laws and international copyright agreements, as well as other intellectual property laws and agreements.

Limitations on Reverse Engineering, Decompilation, and Disassembly
You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the
extent that such activity is expressly permitted by applicable law notwithstanding this limitation. This also applies to Demo versions.

Separation of Components
The SOFTWARE PRODUCT is licensed as a single product. Its component parts may not be separated for use
on more than one computer. This also applies to demo versions.

Rental
You may not rent, lease, or lend the SOFTWARE PRODUCT. This also applies to demo versions. Software Transfer You may not transfer the rights of this end-user LICENSE AGREEMENT.

Data Transmission
You may not transmit the SOFTWARE PRODUCT, or parts of it, without the prior permission of Corisoft Software.

Termination
The license to use the SOFTWARE PRODUCT ends at the 31st of December, 2050. Without prejudice to any other rights (civil or criminal), Corisoft Software may terminate this LICENSE AGREEMENT if you fail to comply with the terms and conditions of this LICENSE AGREEMENT. In such an event, you must destroy all copies of the SOFTWARE PRODUCT and all of its components.

Upgrades
If the SOFTWARE PRODUCT is labeled as an upgrade, you must be properly licensed to use the SOFTWARE PRODUCT identified by Corisoft Software as being eligible for the upgrade in order to use the SOFTWARE PRODUCT. A SOFTWARE PRODUCT labeled as an upgrade replaces and/or supplements the product that forms the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE AGREEMENT. If the SOFTWARE PRODUCT is an upgrade of a component of a package of software programs that you licensed as a single product, the SOFTWARE PRODUCT may be used and transferred only as part of that single product package and may not be separated for use on more than one computer.


Manage Multiple Projects

Objects and Attributes

ObjectData manages two kind of datas : Objects and Attributes.

An Object can contain objects or attributes. It's commonly represented with a label and an associated icon. An object can't manage objects and attibutes at the same level.

An Attribute is located in an object there is nothing after. An attribute is generally represented with a label and an associated value.

Object are used as levels than attributes are used for storage.

All of these objects and attributes are attached to the root object. Root object contains only objects.

Here is here an example of a "personal contact database"


Manage contacts

Copy, cut and paste - Drag and Drop

Objects and Attributes can be copied, paste and cut though the hierarchical tree.

Objects and Attributes can also be dragged and dropped in respect of the rules defined in the previous chapters.


Agenda entries and project history

Import datas from Text Files

Datas from text files can be imported directly into ObjectData.

There are two kinds of importation allowed into ObjectData.

Users can import attributes directly into a selected object but also object with its attributes.

The format expected for importing attributes is : "label;value". The text file can contain multiple lines defined as described.

Example import a translation dictionnary :

abdicate; abdiquer
abbreviate;abréger
abbot;abbé
...

The format expected for importing objects is a little bit different.

The first line must contain the labels used for attributes, the other lines are the datas themselves.

When importing objects, ObjectData ask for the column which will be used to create the father object for each record.

Example import a contact database :

last name;first name;company;title;phone
sebban;eric;corisoft;project manager;33562626262
smith;john;mif;spy;33123456789
...

if you select "last name" as the object name you will retrieve this result


Don't forget something with to-do list

Export datas to Nokia 7650

Exporting datas to Nokia 7650 is generated in 2 steps.

The first step consist in creating a new text file adpated to the Nokia 7650 viewer.

The second step consist in converting the text file into a sis file for the Nokia 7650 that can be easily tranfered from IR ot BT protocols.

The PC software creates 2 files : the database file in the expected format and the sis file which contains this database file.

When transfered through sis installer, the databases are directly stored in the ObjectData database destination folder.

The databases are stored on the Nokia 7650 into the "c:\corisoft\od" folder.

The viewer uses this path in order to generate the first list of items which contains only databases.

The software calls directly 'makesis.exe' program which is a part of the C++ SDK for series 60. This software is the property of Symbian, all rights reserved.


Add comments to items

Register ObjectData

ObjectData is a shareware. The unregistered version allows a total 7 items per level and 3 levels

ObjectData costs 18£.

ObjectData may be ordered online in following the registration link through Passpoint on http://corisoft.free.fr

Passpoint offer a variety of payment methods other than over the Internet. If you choose to make payment in any of these ways don't forget to write your name, the product you require, and your contact details (email, tel, post). This will be required to complete your order.

Fax: +44 (0)1234 350606
Postal: 44 Harpur Street
Bedford
MK40 2QT
United Kingom

Cheques should be made payable to FullyMobile, the name of our parent company. If you are sending cash in any currency other than UK Pounds please add 10% to cover the costs of exchange.

Passpoint can also accept payment by direct bank tranfer. Our bank account details are as follows:

Account: FullyMobile
Account #: 60630292
Sort code: 20-05-74
Bank: Barlcays Bank
111 High Street
Bedford
MK40 1NJ
United Kingdom